Installation

Installation

Before You Install the Espaco theme

Please be sure you do all the items below, which must be complete before installing any WordPress theme.

  • Choose a hosting company. Choose a hosting dedicated to WordPress hosting.  
  • Get your own domain. Hosting will help and guide how to set your new domain on your new server
  • Install WordPress on your domain. This is the official WordPress tutorial for how to install WordPress, but most WordPress dedicated hostings will do this installation for you  http://codex.wordpress.org/Installing_WordPress#Famous_5-Minute_Install.

Requirements for WordPress

Requirements for Espaco theme

To use Espaco theme, the following requirements must be met by your hosting:

  • WordPress 4.6+
  • PHP 5.6+
  • MySQL 5.6+

For older PHP versions, older than 5.5, there will be errors and the theme will not work at all.  The APIs integrated cannot support such old PHP versions. It is in your benefit to use the newest PHP version as it comes with better speed results too. Please contact hosting to upgrade PHP as it’s a quick job too.

  • max_execution_time 800
  • memory_limit 256M
  • max_input_vars 2000
  • post_max_size 50M or higher
  • upload_max_filesize 50M or higher
  • CURL PHP Extension (For Google Login)

How To check your hosting PHP Limits

Even if you make changes in wp-config.xml, it is possible the limits do not change because your server is limited from server settings. This plugin can help check the server limits https://wordpress.org/plugins/wordpress-php-info/

On shared hosting, the limits will be managed from server end in order to be able to accommodate hundreds/thousands of clients on the same machine. You may not be able to change these recommendations from PHP ini or wp-config.

Was this article helpful to you? Yes No

How can we help?